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1.Introduction

1.1 Document Purpose

This document serves as a complete description of the behavior of Sudokuki. It will list
its functions, its target user base, its operating environment, its various requirements
and so on. It will also include a set of use cases that describe interactions the users will
have with the software. At the time of writing this document, the latest stable release of
Sudokuki is 1.1.5.

1.2 Product Scope

Sudokuki is a free graphical Sudoku game developed in Java. It allows the user to
generate, play and print Sudoku games. It also gives the option of solving games the
user is having trouble with. It offers various difficulty levels and is available in 13
languages.

1.3 Intended Audience and Document Overview

This SRS document is intended for developers, testers and of course end users. It
contains an overall description of the software, followed by specific requirements and
also non-functional ones. It is recommended for the reader to begin with the overview
sections and proceed with the sections that are most pertinent to his/her type.

1.4 Definitions, Acronyms and Abbreviations
GUI = Graphical User Interface

SRS = Software Requirements Specification

1.5 Document Conventions

In general this document follows the IEEE formatting requirements. Arial font 12 was
used to write the majority of it. Italics were used for headers and comments.
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1.6 References and Acknowledgments

Sudokuki home page: http://sudokuki.sourceforge.net/

Sudokuki forums: https://sourceforge.net/p/sudokuki/discussion/

This SRS document was written using the IEEE SRS template as a guide.


http://sudokuki.sourceforge.net/
https://sourceforge.net/p/sudokuki/discussion/

Software Requirements Specification for Sudokuki Page 3

2.Overall Description

2.1 Product Perspective

Sudokuki is a new, self-contained product. It is an open source project that the author
develops in his free time hoping that both new and experienced Sudoku players will find
it fun and useful.

2.2 Product Functionality
A summary of the primary functions Sudokuki offers is as follows:

e Generate a new Sudoku grid

e Print the current grid

e Print 4 grids

e Open and resume a previously saved grid

e Save the current grid

e Download a new version of the project

e Change language

e Enter numbers on the grid

e Enter memos on the grid

e Clear previously entered memos

e Hide previously entered memos

e Clear previous moves

e Choose level of difficulty

e Choose between Arabic and Chinese numbers
e Let Sudokuki enter memos for you

e Automatically resolve the current grid

e Make a customized grid

e Use the help button to find information about the project and its contributors
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2.3

Operating Environment

Sudokuki runs on both GNU/Linux and MS-Windows systems, as well as on MAC OS/X.
In fact Sudokuki runs on all systems that have a Java Runtime Environment, Java
version greater or equal to 1.6 is required.

2.4

User Documentation

The following documents are available along with the project in text format:

COPYING - a document listing public license, copyright and terms and
conditions of use.

HOWTO_RUN_SUDOKUKI — as the name implies, it informs the end user on
how to run Sudokuki on his/her system.

NEWS - offers a link to the project’s forums as well as explains the different
versions of its development status.

README - offers the project's changelog as well as lists various websites
referencing it.
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3. Specific Requirements

3.1 External Interface Requirements
3.1.1 User Interfaces

This is the main graphical user interface of Sudokuki:

r Sudokuki =
File Edit Help
Céea®
6 8
1|3 12
2 |7 1
2 5 4
3 8
2151 6 9
3 9 (2
S 618 7

The current grid takes up the majority of the window and on the top we have the various
buttons and functions.

Clicking on a square of the grid to add a number, the user is presented with the
following GUI:
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r | E; I‘
-
7 8 9
4 5 6
1 2 3

Where he/she can select the number to insert. The “Memos” tab leads the user to the
following GUI:

e | . I
| == |Memos
{ Clear memos
1 B2 [E3
C4 E5 [E6
[7 B8 EH9
= J

Where he/she can insert a memo on the previously selected square.
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Clicking the “About...” option in the “Help” menu leads the user to the following GUI
containing information about the project:

[ R About Sudokuk.. ===

Information }| Contributors | Feedback | Transfer | License|

7|3 4

:
L6

—_
-

23] Y N e

2 -3

3| |4] |5

Sudokuki 1.1.5
Copyright (C) 2007-2012 Sylvain Vedrenne

| Sudokuki on the Web |

———Sj_;———,~,—,—~,—.,—_—™...,

This window also contains the following tabs: Contributors -

[ [ About Sudokuki.. [

| Information [: Contributors || Feedback | Transfer | License |

Aritz Beraza Spanish translations (v1.0)
Jeroen P. Broks Dutch translations

Helene

Danbaabas Greek translations (v1.0)

m

Janis Fisaks Latvian translations
Rafael Ferreira Brazilian Portuguese translations
Stavros Mavrakis Greek translations
Fumiaki Nakanishi Japanese translations

Jeanne Peng Chinese franslations
Claus Poerschke Patches (v1.0) and German translations
Dmitry Salnikov Porfuguese and Russian translations -
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Feedback -

Transfer -

About Sudokuki... e

| Information | Contributors |: Feedback | Transfer | License |

Feel free to request features and report bugs
on the Sudokuki Forums hosted by Sourceforge!

[ Sudokuki Forums ]

7 About Sudokuki... e

| Information | Contributors | Feedback || Transfer | License |

Sudokuki is released under the terms of the GNU General Public License
version 3 or later (GPL v3+).

The full license text is available in the file called COPYING that must be
included in every copy of the program.

This program is Free Software ("Free" as in "Freedom") developped
during the author's free-time in the hope that some users will find it useful,
but WITHOUT ANY WARRANTY of any kind.

You are welcome to transfer this program to other people as long as you
respect the license terms. Read the GNU General Public License for more
details.

Copyright (C) 2007-2012 Sylvain Vedrenne
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And lastly License -

’ About Sudokuki... l = I‘

GNU GENERAL PUBLIC LICENSE =

Version 3, 29 June 2007

Copyright © 2007 Free Software Foundation, Inc. <h

Everyone is permitted to copy and distribute verbatim copies of this
license document, but changing it is not allowed.

Preamble

The GNU General Public License is a free, copvleft license for software
and other kinds of works.

< | mn P

3.2 Functional Requirements

In this section all the different project functions are going to be listed in detail with
specific explanations regarding each function.

3.2.1 Generate a new grid

Sudokuki offers 3 ways of generating a new Sudoku grid. The user can either click on
the appropriate icon which is located on the upper part of the main GUI window (above
the grid),
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(R sudokuki EENEETS)
FilenEdit:Helpm
(RISY=R ) 4 -
[New] 4
9 3 1
6 8
18 4
2 6 9
2
4 3 1(9
9 S
L |2 7 3

click on the “New” option in the “File” tab,

[ it . 3 R
Sudokuki ESREEN S

[File] Edit Help
|:] New Ctrl+N
& Print | 4
& Printx |
s 1
<2 Open Ctrl+0 §
E Saveas  Ctrl+S | 4
# Quit cd«Q | |9
2 8
4 3 1|9
9 S
1 2 7 3

<

or simply press “Ctrl + N” on their keyboard. All three alternatives generate a new game
of Sudoku on the main GUI.
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3.2.2 Print the current grid

The users can print the current grid if they have a printer available. Once the option is
selected, a new GUI appears where the users can specify the name of the printer, the
number of copies etc. The option is accessed either by clicking on the icon at the top of
the main GUI

([ sudokuki ESNEERTS)
File Edit Help
R =R N -
9 S 1
6 8
1|8 4
2 6 9
2 8
4 3 1|9
9 S
1(2 7 3

or by clicking on the “Print” button of the “File” tab

4 z Y
R Sudokuki el
Edit Help

(9 New Ctrl+N

(g) Print 4
& Prifprint the grid] 5 1
[=1 Open Ctrl+0 8

Saveas  Ctrl+S | 4

#l Quit ad«Q | |9

2 8
4 3 1|9
9 S
1|2 7 3
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3.2.3 Print 4 grids

The users can print 4 automatically generated grids if they want. They can later solve
those grids on paper. Once the option is selected, Sudokuki generates 4 random grids
and then sends them to the printer, opening the printer GUI. This option is accessed via
the “Print x 4...” button of the file tab

([ sudokuki ESNEE )
[File] Edit Help
| ] New Ctrl+N
(%; Print 4
txy Printx4... 5 1
[ Open IPrintfot(l,rgridsi
=] Saveas Ctrl+S 4
# Quit Ctrl+Q 9
2
4 3 1]9
9 5
1 [i2 i 3

3.2.4 Open a previously saved grid

The users can open a previously saved grid and resume their work on it. Sudokuki grids
are saved as “.skg” files. When the option is selected, Sudokuki lets the users choose
their desired grid and then shows it on the main GUI. The option can be accessed by
either clicking on the appropriate icon at the top of the main GUI,
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(R sudokuki EENEETST)
FlenEdit: Helpm
== A

Open 4
9 5 1
6 8
1|8 4
2 6 9
2 8
4 3 1|9
9 5
1|2 7 3

clicking on the “Open” button of the “File” tab,

r Sudokuki I I Y. I! g .1
[File] Edit Help )
I:] New Ctrl+N
é Print I 4
[5 Print x 4... 5 n
=] Open Ctrl+0O 8
E Save as|o enl*s | 7
# Quit cr«Q | | 9
: 8
1 3 19
9 5
T <2 7 3

or by pressing “Ctrl + O” on the keyboard.
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3.2.5 Save the current grid

The current grid can be saved at any time as a “.skg” file and stored anywhere the user
wants. The option can be accessed either by clicking on the appropriate icon at the top
of the main GUI,

r Sudokuki =)
File Edit Help
Dasa&®
[Save =s] 4
9 5 1
6 8
1|8 )
2 6 9
2 8
4 3 19
? 5
1 2 7 3

by clicking on the “Save as” button of the “File” tab,

rﬂ Sudokuki ELI-E_hF
[File] Edit Help :
1__7 New Ctrl+N '
(2, Print 4
&) Printx4... 5 1
[ Open Ctrl+0 8
E Saveas  Ctrl+S | 4
&l Quit 9
2 8
3 19
9 S
1 |2 7 3

or by pressing “Ctrl + S” on the keyboard.
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3.2.6 Download new version

The user can update to the newest version of Sudokuki if available. In general, newer
versions of the project mean less bugs, more stable performance and new features.
This option can be accessed either by clicking on the appropriate icon at the top of the
main GUI

([ sudokuki ESNEERTS)
File Edit Help
BRI N -
| Download new version]
9 S 1
6 8
1|8 4
2 6 9
2 8
4 3 1|9
9 S
1(2 7 3

or by clicking on the “Download” button of the “Help” tab

([ sudokuki [ESEE)
File Edit [I—ﬂgj
|:7 élJ E@ Update
| @ Download
9 (] Trand Download new version |
| 5.7 About... :
L8| | | | |14
2 6 9
2 8
1 3 1|9
9 S
1|2 7 3
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3.2.7 Language selection

Sudokuki offers a wide variety of languages for the user to select, including German,
Greek, English, Japanese, Chinese, Latvian, Dutch, Esperanto, French, Portuguese,
Russian and Spanish. The selection can be made by clicking on the appropriate icon at
the top of the main GUI, at which point this window appears,

” ; ~
B Sudokuki =B X
File Edit Help

| Language ﬂ

[ Deutsch EAANVIKG
English (&8 Esperanto
[ Espaniol [l Francais
|[®] B#:E = Latviesu 1

=] Nederlands [ Portugués
Portugués (Brasil) [ Pyccxmi

B

or by clicking on the “Language” button of the “Edit” tab
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r Sudokuki
File [Edit] Help
|:] ’ gh Clear moves
| ¥ Hide memos... 4
—i 9k Level » 1
—‘ b  Numbers L2 N |
_j 24 Language ' ™ Deutsch
T %, Solution... ' EMn.VLK(x
- 1 B English
) |#1 Customgrid |G Esperanto
4 | P Play grid & Espaiol
[ 9 r— ¥ Francais
112 7‘ [&] A%
B Latviesu
B3 Nederlands
Bl Portugués
Portugués (Brasil)
[  Pycckwii
o e

3.2.8 Quit the application

Naturally Sudokuki also comes with the option of quitting the application. The user can
click on the “Quit” command of the “File” tab, or press “Ctrl + Q” on the keyboard.

[File] Edit Help

| ] New Ctrl+N .
;2] Print 4
&) Printx4... 5 1
5 Open Ctrl+0 8
E Saveas  Ctrl+S | 4
#l Quit cad+Q | |9
I Qui.t the.application B
4 3 19
9 S
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3.2.9 Clear all moves

The users can clear all previous moves they made in the current grid. This will reset the
grid to its initial state, useful if it turns out there has been a mistake somewhere. The
option is available on the “Edit” tab

& . )
Sudokuki [N
File [Edit] Help
i__1 é Clear moves

Hide memo Clear all moves
gk Level 19
;;5| Numbers K8 1 “l
? BH Language g 4
| |
“' 7 |\ Solution... ’ 6 I'
|7} Custom grid E
3 2
y 71 [3]6]8
§ =

3.2.10 Hide memos

As the title implies, users also have the option of hiding all previously entered memos,
thus clearing the grid of them. The option is available on the “Edit” tab

File Help
|:| é Clear moves
T I8 i FERREE
3l LJ Hide memos... [, % ,],°3 5
il i
3 T 23 3
I Hide all memos...
Sgi}j Ley >33s0lr o
s3 138l Numbers Me2sle 23] 1
=B L S o
' anguage syt [
2 guag s |17 4
Letai=hy L7 9
‘ . 3 |12
7 | & Solution... » 15 153 6
! 9 9
1 o= ) 3 12
8/ A Custom grid 22sly
13p Play grid i
8 AT ey [ |9
1 1 1 1 1
solr olrsol*’® 3 b A 2
13 |12 [12 3
of W57 [5]13(6]8




Software Requirements Specification for Sudokuki Page 19

3.2.11 Difficulty level selection

Sudokuki offers 5 difficulty levels that apply to different users, from the beginners to the
more experienced. The option to set the level is on the “Edit” tab

r Sudokuki Lil’_lg‘
File [Edit] Help
|:1 é Clear moves ‘

" ¥ Hide memos... '—I_I?
[ e ) Levell
| [3b] Numbers ) Level 2
T EH Language ' Level 3
7 %, Solution... ) o
4] Level 5

|#1  Custom grid o |52
f P  Playgnd
3 2
4 71 1368
.

3.2.12 Numbers format selection

Users have the option of using either Arabic or Chinese/Japanese numbers (kaniji). This
option appears yet again on the “Edit” tab

g — — 5
Sudokuki (B
File [Edit] Help
!:] ‘ r-ﬁ Clear moves
¥ Hide memos.., 5
9k  Level » .
Wa__b] Numbers } @ Arabic
2 EH Language ' Chinese
7 | N Solution.. 4 6
1 |/ Custom grid 8
P Play grid
3 2
4 7 3/6|8
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3.2.13 Solve the current grid

If the users finds the current grid too hard, they can opt to have Sudokuki solve it for
them. There is also the option of automatically filling the grid with memos, helping the
users by excluding some numbers in each square. The options appear on the “Edit” tab

{ N
EX Sudokuki [ESEE
File Help
[ |dh  Clear moves
3 ¥ Hide memos...

%‘ Level » 3
b Numbers > 219
4 Language » 9
% Solution... '1; Memos
e i
= All memos
1 |#  Custom grid
8 | P Playgrid &’ Resolve
7 8 4|6
2 6 7

9

3.2.14 Compose a custom grid

The users also has the option of composing a grid of their own. They are given the
freedom of inserting numbers anywhere they wish on the empty grid and then playing
on that grid. The “Edit tab” again contains this option

File [Edit] Help

l:] #h  Clear moves

3 ¥ Hide memos...
b Level b 3
3B Numbers 4 219

Language » 9

: % Solution... "4 8|1

1 , E?, Custom grid

8 P P[Compose a custom grid... |

7 8 416
2 6 7
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3.2.15 Check for updates

Before actually updating to the newest version of Sudokuki, the user will have to check
if there are any updates available. The option appears on the “Help” tab

(R sudokuki [ESNEE )
File Edit _[Help|

= E@ Update

Cio DC"““nlcaq Check for updates |
1 O Translate this application ‘
| 5.7 About...
6 3] | |8
812 9 3
2 1|5 9
4 6 2
7 4

\

3.2.16 Translate Sudokuki

Users who want to help the project by translating it to their native language can do so by
clicking on the “Translate this application” option on the “Help” tab. The following
window appears with information

r — ~
Translate this application =~ @

You can easily translate Sudokuki into your own language!

Propose your help and get information on how to proceed
on the Translators Forum hosted by Sourceforge:

£ Sudokuki Translators Forum

S e = == * = = 4
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4. Other Non-functional Requirements

4.1 Software Quality Attributes

Sudokuki has been over 4 years in the making and with each new version it becomes
more reliable and robust. It is available to everyone free of charge, it is adaptable and it
still gets translated to many other languages so that everyone can enjoy it. It is very
easy to use thanks to the friendly GUI and the author makes sure to listen to every bug
report or feature request in the forums.



